Highcharts Dashboardsに脆弱性、設定次第で悪意あるスクリプトが実行されるおそれ
概要
Highcharts Dashboardsの1.0.0から4.2.1までには、chartConstructorの検証不足により、ダッシュボードの設定を操作できる攻撃者がHTMLやイベントハンドラーを実行できる脆弱性があります。ボードを表示するだけで成立し、利用者による操作は必要ありません。修正版は4.2.2で、最新の情報を確認して更新してください。
AI要約
外部の AI が作成した要約です。誤りを含むことがあります。重要な判断の前に、下の原文と参照URLを確認してください。
Highcharts Dashboardsの1.0.0から4.2.1までには、chartConstructorの検証不足により、ダッシュボードの設定を操作できる攻撃者がHTMLやイベントハンドラーを実行できる脆弱性があります。ボードを表示するだけで成立し、利用者による操作は必要ありません。修正版は4.2.2で、最新の情報を確認して更新してください。
影響パッケージ
| 種類 | パッケージ | 影響を受ける版 | 直った版 |
|---|---|---|---|
| highcharts | highcharts | — | — |
| @highcharts | dashboards | — | — |
原文の説明 取得元が公開している説明をそのまま載せています (多くは英語)。
Highcharts JS is a JavaScript charting library based on SVG. From 1.0.0 until 4.2.2, Highcharts Dashboards uses chartConstructor as an unchecked property lookup in the Highcharts namespace and invokes the selected member with the component container and chartOptions. An attacker who controls dashboard configuration can select a public utility function instead of a supported chart constructor, causing attacker-controlled options to be copied to the container as properties or attributes. Markup and event handlers can then execute in the hosting page origin when the board renders. No user interaction beyond rendering the board is required. This issue is fixed in 4.2.2.
出典: CVE.org (CVE Program・cvelistV5) NVD
参照URL
- web github.com
- web github.com
- web github.com