本文へ移動
English version →

同じ製品で同じ時期に公表された 8 件の脆弱性の 1 つです。まとめた解説: Apache Juneauに脆弱性、9.2.1で修正版が公開

重大 10.0

Insufficiently Protected Credentials vulnerability in Apache Juneau. The Apache Juneau...

CVE-2026-73116 SecPulse初出

影響パッケージ

種類パッケージ影響を受ける版修正版
Apache Software Foundation Apache Juneau
9.2.1 未満
9.2.1
原文の説明 取得元が公開している説明をそのまま載せています (多くは英語)。

Insufficiently Protected Credentials vulnerability in Apache Juneau.

The Apache Juneau RestClient followed HTTP redirects while keeping credential headers from the original request, so a server that redirected the client to a different host or port, or from HTTPS to HTTP, could receive headers such as Authorization, Cookie, Proxy-Authorization and X-API-Key.

This issue affects Apache Juneau: through 9.2.0.

Users are recommended to upgrade to version 9.2.1, which fixes the issue. The fix applies to HTTP clients created by the RestClient builder; applications that supply their own HttpClient must disable automatic redirects or strip credential headers on cross-origin redirects themselves.

出典: oss-security (Openwall) NVD GitHub Advisory

参照URL

当サイトでは、アクセス解析と広告の効果測定のために Cookie を使います。株式会社Game のサイト共通の設定です。 詳しく