Skip to content
Unrated

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when...

CVE-2026-114422 First seen on SecPulse

Affected packages

EcosystemPackageAffectedFixed
CVE Enable Media Replace
≥ 4.1.4, < 4.2.3
4.2.3
Original description The description as published by the source.

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server.
This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4.

Source: CVE.org (CVE Program・cvelistV5) NVD GitHub Advisory

References

We use cookies for analytics and ad measurement. This setting applies to all Game co., Ltd. sites. Details