本文へ移動
English version →
未評価

XS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds...

CVE-2026-115946 SecPulse初出

影響パッケージ

種類パッケージ影響を受ける版修正版
https://cpan.org/modules XS-libbrotli
1.2.1.0 未満
1.2.1.0
原文の説明 取得元が公開している説明をそのまま載せています (多くは英語)。

XS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds write in the decoder.

Affected versions compile a bundled brotli into static archives that dependent XS modules link against at build time, rather than using the system library. The bundled copy, 1.0.7 or 1.1.0 across the range, carries the decoder out-of-bounds write described in CVE-2026-111497. Version 1.2.1.0 updates it to brotli 1.2.1.

XS::libbrotli has no Perl interface, so the decoder is reached through any dependent module that decompresses untrusted data with it. An attacker supplying a crafted brotli stream can corrupt decoder state, disclose memory, crash the process, or potentially execute arbitrary code. Upgrading the system brotli does not remediate this.

出典: CVE.org (CVE Program・cvelistV5) NVD GitHub Advisory

参照URL

当サイトでは、アクセス解析と広告の効果測定のために Cookie を使います。株式会社Game のサイト共通の設定です。 詳しく