Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its...
影響パッケージ
| 種類 | パッケージ | 影響を受ける版 | 直った版 |
|---|---|---|---|
| Apache Software Foundation | Apache Kafka |
2.4.0 以上 4.2.2 未満 4.3.0 以上 4.3.2 未満 |
4.2.2 4.3.2 |
原文の説明 取得元が公開している説明をそのまま載せています (多くは英語)。
Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations.
Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime.
An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker.
Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.
出典: CVE.org (CVE Program・cvelistV5) NVD GitHub Advisory
参照URL
- web kafka.apache.org
- web nvd.nist.gov
- web github.com