Skip to content
Unrated

Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its...

CVE-2026-116593 First seen on SecPulse

Affected packages

EcosystemPackageAffectedFixed
Apache Software Foundation Apache Kafka
≥ 2.4.0, < 4.2.2
≥ 4.3.0, < 4.3.2
4.2.2
4.3.2
Original description The description as published by the source.

Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations.
Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime. 

An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker.

Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.

Source: CVE.org (CVE Program・cvelistV5) NVD GitHub Advisory

References

We use cookies for analytics and ad measurement. This setting applies to all Game co., Ltd. sites. Details