Skip to content
A detailed explainer is available in Japanese. Read the Japanese explainer
High 9.0

Flowise 3.1.4以前にコマンド実行の脆弱性

CVE-2026-119978 First seen on SecPulse

Summary

Flowise 3.1.4以前で、ログイン済みの利用者がサンドボックスを抜けてOSコマンドを実行できる脆弱性が公表されました。版とALLOW_BUILTIN_DEPの設定を確認し、ベンダーの告知で修正版を探してください。

AI summary

Written by an external AI model and may contain mistakes. Check the original description and references below before acting on it.

Flowise 3.1.4以前で、ログイン済みの利用者がサンドボックスを抜けてOSコマンドを実行できる脆弱性が公表されました。版とALLOW_BUILTIN_DEPの設定を確認し、ベンダーの告知で修正版を探してください。

Affected packages

EcosystemPackageAffectedFixed
FlowiseAI Flowise
≤ 3.1.4
—
Original description The description as published by the source.

Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the vm2/@flowiseai/nodevm JavaScript sandbox. An authenticated user with access to the /api/v1/node-custom-function endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's file:// URL handling. In versions 3.0.8–3.1.2 exploitation requires ALLOW_BUILTIN_DEP=true; earlier versions are exploitable by default. Fixed in 3.1.3.

Source: CVE.org (CVE Program・cvelistV5) NVD GitHub Advisory

References

We use cookies for analytics and ad measurement. This setting applies to all Game co., Ltd. sites. Details