@fastify/http-proxyに脆弱性、11.6.6で修正
Summary
Fastify用プロキシの@fastify/http-proxyの9.0.0〜11.6.5に、転送先パスの制限を外部から破られる脆弱性が公表されました。prefixとrewritePrefixで転送先を固定している構成なら、11.6.6以降へ更新してください。
AI summary
Produced by SecPulse using an external AI model; it may contain mistakes. Check the original description and references below before acting on it.
Fastify用プロキシの@fastify/http-proxyの9.0.0〜11.6.5に、転送先パスの制限を外部から破られる脆弱性が公表されました。prefixとrewritePrefixで転送先を固定している構成なら、11.6.6以降へ更新してください。
Affected packages
| Ecosystem | Package | Affected | Fixed |
|---|---|---|---|
| @fastify/http-proxy | @fastify/http-proxy |
≥ 9.0.0, < 11.6.6 |
11.6.6 |
Original description The description as published by the source.
@fastify/http-proxy is a Fastify plugin that proxies HTTP requests to an upstream server under a configured prefix. In versions 9.0.0 through 11.6.5, when an application uses parameterized prefix and rewritePrefix options to pin clients to a fixed upstream path, the plugin substitutes URL-decoded route parameters into rewritePrefix without re-encoding them. A parameter value that encodes a path separator together with a fragment or query delimiter therefore decodes into real separators and delimiters that inject extra upstream path segments and strip the mandatory suffix the rewritePrefix was meant to enforce, without using any dot-dot traversal. An unauthenticated remote attacker can use this to reach upstream locations outside the intended prefix, leading to path-restriction bypass and, depending on the upstream, server-side request forgery or authorization bypass in the proxied service. The issue is fixed in @fastify/http-proxy 11.6.6, and users should upgrade to 11.6.6 or later. There is no workaround other than upgrading.
Source: CVE.org (CVE Program・cvelistV5) NVD
References
- web github.com
- web cna.openjsf.org