Skip to content
A detailed explainer is available in Japanese. Read the Japanese explainer
Critical 10.0

Apache Juneauに脆弱性、9.2.1で修正版が公開

CVE-2026-73098 First seen on SecPulse

Summary

Apache Juneau 9.2.0以前に、解析時に外部から指定したクラスを初期化させられる脆弱性があり、Javaでこのライブラリを使うシステムが対象です。9.2.1へ更新し、自社のアプリが外部入力を解析しているかも確認してください。

AI summary

Produced by SecPulse using an external AI model; it may contain mistakes. Check the original description and references below before acting on it.

Apache Juneau 9.2.0以前に、解析時に外部から指定したクラスを初期化させられる脆弱性があり、Javaでこのライブラリを使うシステムが対象です。9.2.1へ更新し、自社のアプリが外部入力を解析しているかも確認してください。

Affected packages

EcosystemPackageAffectedFixed
Apache Software Foundation Apache Juneau
< 9.2.1
9.2.1
Original description The description as published by the source.

Improper control of dynamically-loaded code vulnerability in Apache Juneau.

When Apache Juneau parses a value into a property of type java.lang.Class (including parameterized forms), the default class swap loaded the named class with initialization enabled, so input naming a class on the application classpath ran that class's static initializer. The impact depends on the classes present in the deployment.

This issue affects Apache Juneau: through 9.2.0.

Users are recommended to upgrade to version 9.2.1, which fixes the issue.

Source: oss-security (Openwall) NVD GitHub Advisory

References

We use cookies for analytics and ad measurement. This setting applies to all Game co., Ltd. sites. Details