Skip to content
High 8.8

Apache OFBizにリモートから任意のOSコマンドを実行される脆弱性

CVE-2026-82910 First seen on SecPulse

Summary

Apache OFBiz 24.09系の24.09.08より前には、認証済みの攻撃者が1回のGETリクエストでOFBizのサービスアカウントとしてOSコマンドを実行できる脆弱性があります。影響を受けるのは24.09.08より前のすべてのプラットフォームです。修正版の24.09.08へ更新してください。

AI summary

Produced by SecPulse using an external AI model; it may contain mistakes. Check the original description and references below before acting on it.

Apache OFBiz 24.09系の24.09.08より前には、認証済みの攻撃者が1回のGETリクエストでOFBizのサービスアカウントとしてOSコマンドを実行できる脆弱性があります。影響を受けるのは24.09.08より前のすべてのプラットフォームです。修正版の24.09.08へ更新してください。

Affected packages

EcosystemPackageAffectedFixed
Apache Software Foundation Apache OFBiz
< 24.09.08
24.09.08
Original description The description as published by the source.

Improper Neutralization of Special Elements Used in a Template Engine ('Server-Side Template Injection') in MacroScreenRenderer in Apache OFBiz 24.09 before 24.09.08 on all platforms allows a remote authenticated attacker holding only the two view permissions of a control-servlet webapp (e.g. CATALOG_VIEW and OFBTOOLS_VIEW on /catalog, held by OFBiz's own shipped order-entry clerk role) to execute arbitrary operating system commands as the OFBiz service account with a single GET request, by placing an apostrophe followed by FreeMarker expression source in a screen link parameter value, because renderLink concatenates link parameter values verbatim between apostrophes into an unquoted, unescaped template-source string that is compiled and evaluated at render time, allowing the injected expression to reach the allow-listed FlexibleStringExpander.expandString call and, through a runtime-assembled Groovy interpolation, unsandboxed code execution. Users are recommended to upgrade to version 24.09.08, which fixes this issue.

Source: CVE.org (CVE Program・cvelistV5) NVD GitHub Advisory

References

We use cookies for analytics and ad measurement. This setting applies to all Game co., Ltd. sites. Details