Vulnerability in qtwebkit-opensource-src
Auto-generated summary
Assembled by SecPulse from the source data (CVSS, CWE, affected versions) using templates — no AI involved. Check the original description and references below for exact details.
A vulnerability tracked as UBUNTU-CVE-2024-27834 has been found in qtwebkit-opensource-src.
Data can be tampered with by attackers.
What to do: upgrade qtwebkit-opensource-src to 2.44.2-0ubuntu0.22.04.1 or later.
If unsure, ask your IT team or search "qtwebkit-opensource-src UBUNTU-CVE-2024-27834" on the vendor's site.
UBUNTU-CVE-2024-27834 (qtwebkit-opensource-src)
Attack vector: local / no user interaction
Patched: 2.44.2-0ubuntu0.22.04.1 — apply immediately
Plan: 1) Audit SBOM/dependencies, 2) Stage→prod upgrade, 3) Add WAF/proxy monitoring on affected endpoints, 4) Hunt IOCs in logs.
Refs: see the GHSA / vendor advisory / patched release linked on this page.
A vulnerability (unclassified) exists in qtwebkit-opensource-src.
Check the vendor advisory for the affected versions of qtwebkit-opensource-src.
Severity: ?. Data can be tampered with by attackers.
Update to 2.44.2-0ubuntu0.22.04.1.
Until the patch is applied: disable the affected feature, apply WAF rules, or restrict access via network ACLs.
Search webserver/proxy logs for unusual request patterns matching this CVE's known IOCs. Run grep -r 'qtwebkit-opensource-src' . against your dependency files (package-lock.json, requirements.txt, go.sum) to find affected services.
Response actions
Concrete steps and command examples for SOC/SRE teams to execute in order
-
1
Identify exposureidentify
grep -r 'qtwebkit-opensource-src' . | grep -v node_modulesリポジトリと本番環境の依存ファイル (package-lock.json / requirements.txt / go.sum / Gemfile.lock 等) で
qtwebkit-opensource-srcを grep し、稼働しているサービス・バージョンを把握する。 -
2
Apply patchpatch
Upgrade qtwebkit-opensource-src to 2.44.2-0ubuntu0.22.04.1ステージング環境で 2.44.2-0ubuntu0.22.04.1 に上げて回帰テスト → 本番反映。回帰テストはアプリの主要ハッピーパスを含めること。
-
3
Post-deployment verificationverify
Confirm patched version is live in productionパッチ適用後、ステージングで PoC または同等の悪用パターンを再現して脆弱性が閉じたことを確認。本番ではアクセスログ・WAF でアラート再発が無いか継続監視。
Affected packages
| Ecosystem | Package | Affected | Fixed |
|---|---|---|---|
| Ubuntu:16.04:LTS | qtwebkit-opensource-src |
All versions |
— |
| Ubuntu:16.04:LTS | webkit2gtk |
All versions |
— |
| Ubuntu:16.04:LTS | qtwebkit-source |
All versions |
— |
| Ubuntu:16.04:LTS | webkitgtk |
All versions |
— |
| Ubuntu:18.04:LTS | webkit2gtk |
All versions |
— |
| Ubuntu:18.04:LTS | qtwebkit-opensource-src |
All versions |
— |
| Ubuntu:18.04:LTS | qtwebkit-source |
All versions |
— |
| Ubuntu:18.04:LTS | webkitgtk |
All versions |
— |
| Ubuntu:20.04:LTS | webkit2gtk |
All versions |
— |
| Ubuntu:20.04:LTS | qtwebkit-opensource-src |
All versions |
— |
| Ubuntu:20.04:LTS | wpewebkit |
All versions |
— |
| Ubuntu:22.04:LTS | qtwebkit-opensource-src |
All versions |
— |
| Ubuntu:22.04:LTS | webkit2gtk |
< 2.44.2-0ubuntu0.22.04.1 |
2.44.2-0ubuntu0.22.04.1 |
| Ubuntu:22.04:LTS | wpewebkit |
All versions |
— |
| Ubuntu:24.04:LTS | qtwebkit-opensource-src |
All versions |
— |
| Ubuntu:24.04:LTS | webkit2gtk |
< 2.44.2-0ubuntu0.24.04.1 |
2.44.2-0ubuntu0.24.04.1 |
Original description The description as published by the source.
The issue was addressed with improved checks. This issue is fixed in Safari 17.5, iOS 16.7.8 and iPadOS 16.7.8, iOS 17.5 and iPadOS 17.5, macOS Sonoma 14.5, tvOS 17.5, watchOS 10.5. An attacker with arbitrary read and write capability may be able to bypass Pointer Authentication.
Source: OSV.dev (Open Source Vulnerabilities) OSV
References
- advisory ubuntu.com
- report ubuntu.com
- report cve.org
- report webkitgtk.org